Информатика, вопрос задал hollyhelly79 , 7 лет назад

СРОЧНО!!! ДЛЯ Python 3!!!
Площадь треугольника 2
Напишите программу, которая вычисляет площадь треугольника, если даны только две стороны треугольника, и угол между данными сторонами.

Вводные данные: на первой строке число N, количество треугольников. Затем на N строках, 3 числа: первые две стороны треугольника, а последнее число угол между этими сторонами со значением в градусах.

Выходные данные: для каждого треугольника на N строках значение площади, которое округлено до 5 знака после точки. Используйте функцию для вычисления площади для каждого треугольника.
Ввод:
4
13 15 30
12 16 48
16 18 9
14 16 111

Вывод должен быть таким:
48.75
71.3419
22.52656
104.56101

Ответы на вопрос

Ответил Omikami
0

from math import sin, radians

n = int(input())

output = []

for i in range(n):

   x = [int(k) for k in input().split()]

   output.append(round(0.5*x[0]*x[1]*sin(radians(x[2])), 5))

for i in output:

   print(i)

Новые вопросы