Информатика, вопрос задал wentonrust , 7 лет назад

Срочно!!! Для python 3!!!
Опросы
В городе были проведены N опросов. В каждом опросе участники ставили "Да" или "Нет". Для каждого опроса результат считается положительным, если в любом из них количество положительных больше числа отрицательных. Напишите программу, которая выводит результат для каждого из опросов.

Вводные данные: в первой строке пишется число N, количество опросов. Затем пишется N строк, на которых написаны числа через пробел. Числа являются 1 или 0, что означает "Да" или "Нет".

Выходные данные: для каждого из опросов на отдельной строке вывести "Positive", если количество 1 больше или равно количеству 0, и "Negative" в противном случае. Напишите данную программу используя функции.

Ввод:
5
1 0 0 1 1
0 1
1
0 1 0 1 0
1

Вывод должен быть такой:
Positive
Positive
Positive
Negative
Positive

Ответы на вопрос

Ответил Omikami
0

n = int(input())

output = []

for i in range(n):

   x = [int(k) for k in input().split()]

   if (sum(filter(lambda j: j == 1, x))  >= len(x) / 2 ):

       output.append('Positive')

   else:

       output.append('Negative')

for i in output:

   print(i)

Ответил arturovartem20
0
О великий Omikami
Ответил arturovartem20
0
С моим вопросом
Новые вопросы