Информатика, вопрос задал fizell , 1 год назад

СРОЧНО!!!!ДАЮ 40 БАЛЛОВ!!!ЯЗЫК PASCAL!!!Напишите программу,которая найдет произведение вводимых с клавиатуры чисел ,которые заканчиваются на 3 и одновременно делятся на 7 без остатка

Ответы на вопрос

Ответил листиккк
0

Ответ:

program MultiplyThreeSeven;

var

 x: integer; {введенное число}

 p: longint; {переменная для произведения}

begin

 p := 1; {инициализируем значение}

 write('Введите число: ');

 readln(x);

 while x <> 0 do begin {цикл до тех пор, пока не будет введен ноль}

   if (x mod 10 = 3) and (x mod 7 = 0) then {если условие выполнено}

     p := p * x; {умножаем на число}

   write('Введите число: '); {запрашиваем}

Объяснение:

Новые вопросы