Срочно! Даю 40 баллов
Напишите программу в паскале с оператором repeat
Дано целое число N (>0) используя операции деления нацело и взятия остатка от деления, найти количество и сумму его цифр (N=63)
Ответы на вопрос
Ответил raf1O5
0
program raf105;
var abc,a,sum,count: integer;
begin
write('Введите число: ');
readln(abc);
count:= -1;
repeat
a:= abc mod 10;
sum:= sum+a;
count:= count+1;
abc:= abc div 10;
until a=0;
writeln('Сумма цифр: ',sum);
writeln('Количество цифр: ',count);
end.
Новые вопросы