Информатика, вопрос задал mashkawolf , 2 года назад

СРОЧНО ДАЮ 40 БАЛЛОВ
НА ПИТОНЕ!!!Последовательность чисел назовем симметричной, если она одинаково читается как слева направо, так и справа налево. Например, следующие последовательности являются симметричными:
1 2 3 4 5 4 3 2 1
1 2 1 2 2 1 2 1
Вашей программе будет дана последовательность чисел. Требуется определить, какое минимальное количество и каких чисел надо приписать в конец этой последовательности, чтобы она стала симметричной.

Входные данные
Сначала вводится число N — количество элементов исходной последовательности (1 ≤ N ≤ 100). Далее идут N чисел — элементы этой последовательности, натуральные числа от 1 до 9.

Выходные данные
Выведите сначала число M — минимальное количество элементов, которое надо дописать к последовательности, а потом M чисел (каждое — от 1 до 9) — числа, которые надо дописать к последовательности.

Примеры
входные данные
9
1 2 3 4 5 4 3 2 1
выходные данные
0
входные данные
5
1 2 1 2 2
выходные данные
3
1 2 1
входные данные
5
1 2 3 4 5
выходные данные
4
4 3 2 1​

Ответы на вопрос

Ответил lingvini2013
3

def isPalindrome(string):

   reverse_string = string[::-1]

   if (string == reverse_string):

       return True

   else:

       return False

n = int(input())

string = "".join(str(input()).split())

for i in range(0, n):

   if isPalindrome(string[i:n]):

       mirror = string[:-(n - i)]

       mirror = mirror[::-1]

       break

array = [char for char in mirror]

print(len(array))

for item in array:

   print(item, end = " ")

Новые вопросы