Информатика, вопрос задал zlodeika225 , 2 года назад

СРОЧНО!!! ДАЮ 30 БАЛЛОВ!!!
Язык - Python
Развернуть элементы с нечетными индексами
Вам дан список целых чисел. Разверните элементы с нечетными индексами.
Входные данные
Вводится список чисел. Все числа списка не превосходят по модулю 100 и находятся на одной строке.
Выходные данные
Выведите получившийся список.
Примеры
Ввод
1 2 3 4 5
Вывод
1 4 3 2 5

Ответы на вопрос

Ответил KnowsUser1
2

Ответ:

--- Python 3.8.3 ---

RawList = list(map(int, input().split()))

fLen = len(RawList)

HalfLen = fLen//2

for i in range(1, HalfLen+1, 2):

   RawList[i], RawList[fLen-i-1] = RawList[fLen-i-1], RawList[i]

print(*RawList)

Новые вопросы