Информатика, вопрос задал texin508 , 2 года назад

СРОЧНО! ДАЮ 30 БАЛЛОВ!

Составить программу в Паскале, где с клавиатуры вводится число (нечетное), а на экран выводится квадрат (матрица)

Например, Вводится 3
1 1 1
1 2 1
1 1 1

Вводится 5

1 1 1 1 1
1 2 2 2 1
1 2 3 2 1
1 2 2 2 1
1 1 1 1 1
и т.д.


texin508: 1 1 1 1 1
1
1
1
1
texin508: 1 1 1 1 1
1 2 2 2 1
1 2 3 2
1 2 2 2
1 1 1 1 1

Ответы на вопрос

Ответил iknowthatyoufeelbro
1

Ответ:

program ideone;

uses Math;

var

 n, i, j: Integer;

begin

 read(n);

 for i := 0 to n-1 do

 begin

   for j := 0 to n-1 do

   begin

     if (j > 0) then write(' ');

     write(Min(Min(i, j), Min(n-i-1, n-j-1))+1);

   end;

   writeln;

 end;

end.

Новые вопросы