Информатика, вопрос задал vanyaprodayko , 2 года назад

СРОЧНО!!!!!!!
Дан массив целых чисел, состоящий из 15 элементов. Значение элементов массива задаются случайным образом в диапазоне от 10 до 80. Написать программу, которая считает количество элементов массива, значение которых больше 50


malikserserrt: паскаль или питон?
vanyaprodayko: паскаль

Ответы на вопрос

Ответил malikserserrt
1

Ответ:

var A : array [10..80] of integer;

var N, x, i, c, k : integer;

begin

readln(N);

for i:=1 to N do begin

A[i] := i;

read(A[i]);

end;

readln(x);

c := 0;

for k:=1 to N do

if A[k] = x then begin

c := c + 1;

end;

writeln(c);

end.

Объяснение:


vanyaprodayko: а почему не віполняется
malikserserrt: var A : array [10..80] of integer;

var N, x, i, c, k : integer;

begin

readln(N);

for i:=1 to N do begin

A[i] := i;

read(A[i]);

end;

readln(x);

c := 0;

for k:=10 to N do

if A[k] = x then begin

c := c + 10;

end;

writeln(c);

end.
Новые вопросы