СРОЧНО! ДАМ БАЛЛЫ ПОМОГИТЕ!!!
1. напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 3 и окончивающихся на 4. программа получает на вход натуральные числа,кол-во вселенных чисел неизвестно ,последовательность чисел заканчивается числом 0(0-признак окончания ввода не входит в последовательность) количество чисел не превышает 1000. введеные числа не превышают 3000. программа должна вывести одно число: сумму всех натуральных чисел кратнчых 3 и окончивпющихся на 4
входные данные
16
24
56
22
54
0
выходные данные
78
Приложения:

iknowthatyoufeelbro:
Язык паскаль?
Ответы на вопрос
Ответил iknowthatyoufeelbro
1
Ответ:
Исходник ниже
Объяснение:
program task;
var
x, sum: Integer;
begin
sum := 0;
while True do
begin
read(x);
if x = 0 then break;
if (x mod 3 = 0) and (x mod 10 = 4)
then sum := sum + x;
end;
writeln(sum);
end.
Новые вопросы