Информатика, вопрос задал carolinefild51 , 1 год назад

СРОЧНО ДАМ 50 БАЛЛОВ составьте программу в паскале abs. найти произведение чисел от 1 до n. через цикл while и repeat​

Ответы на вопрос

Ответил gfhjkmgfhjkm20
1

Ответ:

1. while

var i,n: integer;

p: real;

begin

write('Введите число: ');//n<171

read(n);

p:=1;

i:=1;

while i<=n do

begin

p:=p*i;

i:=i+1

end;

write ('Произведение чисел от 1 до ',n,' равно ',p)

end.

2. repeat

var i,n: integer;

p: real;

begin

write('Введите число: ');//n<171

read(n);

p:=1;

i:=1;

repeat

p:=p*i;

i:=i+1

until i>n;

write ('Произведение чисел от 1 до ',n,' равно ',p)

end.

Новые вопросы