СРОЧНО!!!!!Дам 20 баллов!!!!Составить программу ввода с клавиатурой целых чисел от 1 до 10 и вывода на экран элементов массива с нечетными значениями
Ответы на вопрос
Ответил danulpopov
0
var
a:array[1..10]of integer;
i:integer;
Begin
For i:= 1 to 10 do
begin
Read(a[i]);
if a[i] mod 2 <>0 then Write(a[i], ' ');
end;
end.
/~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~/
//Более современное решение
// PascalABC.NET 3.3, сборка 1576 от 16.11.2017
// Внимание! Если программа не работает, обновите версию!
Begin
var a:= ReadlnString('Введите массив').ToIntegers;
SetLength(a, 10);
a.Where(t->t.isOdd).Println;
end.
a:array[1..10]of integer;
i:integer;
Begin
For i:= 1 to 10 do
begin
Read(a[i]);
if a[i] mod 2 <>0 then Write(a[i], ' ');
end;
end.
/~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~/
//Более современное решение
// PascalABC.NET 3.3, сборка 1576 от 16.11.2017
// Внимание! Если программа не работает, обновите версию!
Begin
var a:= ReadlnString('Введите массив').ToIntegers;
SetLength(a, 10);
a.Where(t->t.isOdd).Println;
end.
Новые вопросы