Информатика, вопрос задал Ianking , 1 год назад

СРОЧНО, 60 БАЛОВ.

Необходимо написать программу, которая выполняет следующие действия: 1. Запрашивает у пользователя 13 оценок, полученных учащимися за контрольную работу (от 1 до 5), (использовать оператор цикла for или while , запрашивает значит будет использоваться оператор input); 2. Определяет и выводит количество полученных пятёрок, четвёрок, троек, двоек и единиц, (используется оператор для определения if , elif и для вывода оператор print); 3. Выдаёт сообщение о неправильном вводе оценки, например, 0, 6 и т.д. (используется else : print ("такой оценки не существует") .

Ответы на вопрос

Ответил DlowPro
0

Ответ:

Как я понял это Python:

ones = 0

tw = 0

th = 0

fo = 0

fi = 0

for i in range(1, 14):

   flag = True

   while flag:

       point = int(input('Введите оценку '))

       if 0 < point <= 5:

           if point == 1:

               ones += 1

           elif point == 2:

               tw += 1

           elif point == 3:

               th += 1

           elif point == 4:

               fo += 1

           elif point == 5:

               fi += 1

           flag = False

       else:

           print('Вы ввели неверную оценку')

print('Получено:\nЕдиниц - ' + str(ones), '\nДвоек - ' + str(tw), '\nТроек - ' + str(th), '\nЧетверок - ' +str(fo), '\nПятерок - ' +str(fi))

   

 

Объяснение:


Ianking: Да,это пайтон, но мне выдает ошибку в строке flag = True
Ianking: File "main.py", line 10
if 0 ^
SyntaxError: invalid syntax
DlowPro: Все работает, если ты использовал онлайн пайтон, то попробуй расставить табуляцию сам (не автоматически)
Новые вопросы