СРОЧНО !!! 40 БАЛЛОВ .В ПАСКАЛЕ.
напишите программу, которая вводит натуральное число n и выводит на экран все натуральные числа , не превосходящие n и делящиеся на каждую из своих цифр.
Ответы на вопрос
Ответил ladalol9768i5
1
Программа: Var number, i, dv, md : integer; flag : boolean; Begin readln(number); For i := 1 To number Do Begin flag := true; dv := i; While dv > 0 Do Begin md := dv Mod 10; dv := dv Div 10; If (md = 0) Or (md = 1) Then Continue; If i Mod md = 0 Then Begin flag := false; break; End End; If flag Then write(i, ' '); End; End.
Новые вопросы
Другие предметы,
1 год назад
Английский язык,
1 год назад
Математика,
2 года назад
Геометрия,
7 лет назад