Информатика, вопрос задал prshlts024 , 7 лет назад

СРОЧНО!!! 40 БАЛЛОВ!! ДЛЯ Python 3!!!
Сумма максимальных

Напишите программу, которая будет вычислять сумму максимальных значения из каждого списка чисел.

Вводные данные: в первой строке число N, количество списков с числами. Затем N строк, на каждой строке числа написанные через пробел.

Выходные данные: сумма максимальных значений каждого списка.

Ввод:
4
2 20 1 7 8
9 19
10 8 8 13 2 17
6 9 9

Вывод должен быть таким:
65

Ответы на вопрос

Ответил KnowsUser1
0

Ответ:

lists = [list(map(int, input().split())) for i in range(int(input()))]

max_summ = 0

for lst in lists:

   max_summ += max(lst)

print(max_summ)

Приложения:
Новые вопросы