Информатика, вопрос задал 54353543 , 2 года назад

Срочно, 35 баллов!!!


Написать программу в PascalABC.net:

У трёх 6-значных чисел найти:

- произведение нечётных цифр


restIess: с клавы числа вводим?
54353543: Всмысле? Ну можно и письменно, если так удобней
restIess: В прямом смысле, числа можно в программе прописать, а можно просить пользователя ввести с клавиатуры)
54353543: Давайте так как вам будет удобнее, мне главное чтобы решение было

Ответы на вопрос

Ответил restIess
0

var

pr1,pr2,pr3,a,b,c : integer;

begin

readln(a,b,c);

a := abs(a);

b := abs(b);

c := abs(c);

pr1 := 1;

pr2 := 1;

pr3 := 1;

while (a > 0) and (b > 0) and (c > 0) do

begin

if (a mod 10)mod 2 <> 0 then

pr1 := pr1 * (a mod 10);

a := a div 10;

if (b mod 10)mod 2 <> 0 then

pr2 := pr2 * (b mod 10);

b := b div 10;

if (c mod 10)mod 2 <> 0 then

pr3 := pr3 * (c mod 10);

c := c div 10;

end;

writeln(pr1,' ', pr2,' ',pr3);

end.


54353543: Спасибо огромное!
Ответил BobbyFresnel
0

## uses School;

var P: integer -> integer := x -> x.Digits.Where(d -> d.IsOdd).Product;

ReadArrInteger(3).Select(n -> P(n)).Print

Приложения:
Новые вопросы