Информатика, вопрос задал Multioproggraming , 2 года назад

Срочно 30 баллов за решение
Напишите программу, которая просит пользователя ввести целое число N и M, которые являются количеством строк и столбцов для массива. Программа должна предложить пользователю ввести NxM целых чисел и хранить их в двумерном массиве. Затем программа должна вывести общее количество отрицательных элементов и других в табличной форме.
Решение задачи C++

Приложения:

Ответы на вопрос

Ответил asdetass
0

Ответ:

#include <iostream>

int main() {

 int m, n, neg_sum = 0;

 std::cin >> n >> m;

 int** A = new int*[n];

 for (int i = 0; i < n; ++i) {

   A[i] = new int[m];

 }

 

 for (int i = 0; i < n; ++i) {

   for (int k = 0; k < m; ++k) {

     std::cin >> A[i][k];

     if (A[i][k] < 0) {

       ++neg_sum;

     }

   }

 }

 std::cout << neg_sum << std::endl;

 for (int i = 0; i < n; ++i) {

   for (int k = 0; k < m; ++k) {

     if (A[i][k] < 0) {

       std::cout << 'x' << ' ';

     } else {

       std::cout << A[i][k] << ' ';

     }

   }

   std::cout << std::endl;

 }

 std::cin.get();

 for (int i = 0; i < n; ++i) {

   delete [] A[i];

 }

 delete [] A;

 return 0;

}

Объяснение:

Качественное объяснение можно найти по запросу "Двумерный динамический массив c++ пример. Создание, заполнение, удаление. Динамические массивы. #56" в ютуб.

Новые вопросы