Информатика, вопрос задал jsdkgljskdrjg , 2 года назад

СРОЧНО!!!
3. Используя цикл «for», написать программу на языке С++ для решения следующей зада-чи: Среди всех двузначных чисел найти количество таких, у которых удвоенное произ-ведение цифр кратно 3.

Например, у числа 23 удвоенное произведение цифр 2*(2*3) = 18, т.е. кратно 3, а у числа 25 удвоенное произведение цифр 2*(2*5) = 20 не кратно 3. Определите, сколько чисел удо-влетворяет задаче


sahnenkoolexy: извини, я розумею только язык Pythot

Ответы на вопрос

Ответил Arkassssha
0

Код программы:

#include <iostream>

using namespace std;

int main()

{

   int i, kol = 0;;

   for(i = 10; i < 99; i++){

       if( (2 * ((i % 10) * (i /10))) % 3 == 0){

           ++kol;

       }

   }

   cout<<"Количество чисел: "<<kol<<endl;

   return 0;

}

Новые вопросы