Информатика, вопрос задал 1111111111111100 , 2 года назад

СРОЧНО
§ 3.3, в тетради написать программу подсчета суммы и произведения цифр произвольного четырехзначного числа, введенного с клавиатуры.
8 КЛ​

Ответы на вопрос

Ответил vanisherxxx
1

Программа на PascalABC.NET (Подсчёт не только 4 значного числа):

var n, sum, proizv: integer;

begin

sum := 0;

proizv := 1;

write('Введите число: ');

read(n);

while n <> 0 do begin

sum := sum + n mod 10;

proizv  := proizv * (n mod 10);

n := n div 10

end;

writeln('Сумма цифр числа: ', sum);

writeln('Произведение цифр числа: ', proizv);

end.

Приложения:
Новые вопросы