Информатика, вопрос задал RenataLogan , 7 лет назад

Срочно!!
1) а) Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с чётными значениями и количество элементов с нечётными значениями
б) Составьте программу, которая заполняет массив b[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечётными значениями и количество элементов с чётными значениями
2) а) Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с чётными индексами удваивает, а с нечётным утраивает. Выведите на экран исходный и полученный массивы
б) Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10, затем изменяет знак элементов с чётными индексами на противоположный. Выведите исходный и полученный массивы.

Ответы на вопрос

Ответил NaaMan
0

Текста много. Поэтому вставлю фото

Приложения:
Ответил NaaMan
0
//PascalABC (версия 3.4.2, сборка 1889 от 04.12.2018)
// 1a
uses Arrays;
var
sum, count : integer;
begin
var a := CreateRandomIntegerArray(10,1,10);
sum := 0;
count := 0;
foreach var x in a do
if x mod 2 = 0 then
sum += x
else
count += 1;
writeln;
writeln('Массив: ', a);
writeln('Сумма чётных элементов: ', sum);
writeln('Количество нечетных элементов: ', count);
end.
Ответил NaaMan
0
//PascalABC (версия 3.4.2, сборка 1889 от 04.12.2018)
// 1б
uses Arrays;
var
mul, count : integer;
begin
var a := CreateRandomIntegerArray(8,1,10);
mul := 1;
count := 0;
foreach var x in a do
if x mod 2 = 0 then
count += 1
else
mul *= x;
writeln;
writeln('Массив: ', a);
writeln('Произведение нечётных элементов: ', mul);
writeln('Количество чётных элементов: ', count);
end.
Ответил NaaMan
0
//PascalABC (версия 3.4.2, сборка 1889 от 04.12.2018)
// 2a
uses Arrays;

begin
var a := CreateRandomIntegerArray(10,1,10);
writeln;
writeln('Исходный массив: ', a);
foreach var x in range(1,10) do
if a[x-1] mod 2 = 0 then
a[x-1] *= 2
else
a[x-1] *= 3;

writeln('Результат: ', a);
end.
Ответил NaaMan
0
//PascalABC (версия 3.4.2, сборка 1889 от 04.12.2018)
// 2б
uses Arrays;

begin
var a := CreateRandomIntegerArray(10,1,10);
writeln;
writeln('Исходный массив: ', a);
foreach var x in range(1,10) do
if x mod 2 = 0 then
a[x-1] := -a[x-1];

writeln('Результат: ', a);
end.
Новые вопросы