Сравнение чисел(Решить на C++, не кидайте на языке Python!!!)
На вход программе подаются два целых числа m
и n, по модулю не превосходящие2⋅109. Если m≥n, то требуется вывести 1
, в противном случае — любое другое число.
Условный оператор, операторы сравнения, циклы и функции min, max, abs использовать нельзя!
Ответы на вопрос
Если m ≥ n, то m - n ≥ 0, иначе m - n < 0
Если m и n – целые числа и хранятся в переменных типа int, то результат вычисления разности тоже будет целочисленным.
Целое число со знаком в памяти компьютера представлено в виде 4 Байт, первый бит этого набора выделен для хранения знака. Если этот бит равен 0, то число положительное, если 1 – отрицательное.
Зная это, можно написать программу, которая будет выводить 1, если m ≥ n и любое другое число в противном случае. Для этого достаточно воспользоваться побитовыми операциями. В частности, операторами побитового сдвига и побитового И.
- #include <iostream>
- int main() {
- int m, n;
- std::cin >> m >> n;
- std::cout << ((m - n) >> (sizeof(int) - 1)) + 1; // Разбор ниже
- return 0;
- }
Разберем последнюю строчку. В переменной q хранится разность чисел m и n. Нас интересует первый бит этого числа, так как он хранит информацию о том, положительное число или отрицательное. Для этого нам необходимо с помощью побитового сдвига вправо (>>) сдвинуть все биты числа, хранимого в целочисленной переменной q, кроме самого первого бита. Получить количество бит мы можем, воспользовавшись встроенной функцией sizeof(), от полученного значения достаточно отнять единицу.
Как уже упоминалось ранее, нас интересует положительное число в q, а выражение q >> (sizeof(q) - 1) в этом случае вернёт 0. Для того, чтобы результирующее значение было верным необходимо прибавить к результату выражения 1. Таким образом, условие "Если m≥n, то требуется вывести 1, в противном случае — любое другое число." выполняется.
Стоит отметить, что прибавление единицы к выражению – не единственный вариант. Также можно воспользоваться приведением типов. Например, "std::cout << (int)(!(q >> (sizeof(q) - 1)));" выведет тот же результат.