СПОЧНО !!!Написать программу.
Даны числа х, у. Если х и у отрицательны, то каждое значение заменить его модулем; если отрицательно только одно из них, то оба значения увеличить на 0,5; если оба значения неотрицательны, то оба значения увеличить в 10 раз
Ответы на вопрос
Ответил nastikots
1
Ответ:
program z1;
var x,y:real;
begin
writeln('Введите числа: ');
write('x = ');
readln(x);
write('y = ');
readln(y);
if (x<0) and (y<0) then
begin
x:=abs(x);
y:=abs(y)
end
else
if (x>0) and (y>0) then
begin
x:=x*10;
y:=y*10
end
else
if (x<0) or (y<0) then
begin
x:=x+0.5;
y:=y+0.5
end;
write('Результат: x = ',x,' y = ',y);
end.
Объяснение:
abs - возвращает модуль числа x
используем полный условный оператор
if условие then оператор else оператор
Новые вопросы
Русский язык,
2 года назад
Окружающий мир,
2 года назад
Русский язык,
2 года назад
Қазақ тiлi,
2 года назад