Информатика, вопрос задал nadiakoriukovets , 7 лет назад

Списки. Часть 2
• Составить программу, которая будет выводить построчно произвольный рисунок размером не более 60 символов с помощью массива. (Сгенерировать рисунок с помощью онлайн-сервиса, который переводит картинки в ASCII-код).
• В программе можно предусмотреть задержку по времени time. sleep (.3) с помощью модуля time .
• *(на 12 балов) предусмотреть выбор картинки из нескольких (2-3) с помощью условного оператора if-elif-else.

Ответы на вопрос

Ответил lozromanik
0

Відповідь:

1)

t=[" _________",

"|^|     | |",

"| |_____| |",

"|  _____  |",

'| |     | |',

'| |_____| |',

'|_|_____|_|']

for i in t:

   print(i)

2)

import time

t=[" _________",

"|^|     | |",

"| |_____| |",

"|  _____  |",

'| |     | |',

'| |_____| |',

'|_|_____|_|']

for i in t:

   print(i)

   time.sleep(.3)

 3)

import time

def vivod(a):

   for i in a:

       print(i)

f=2

t1=[" _________",

"|^|     | |",

"| |_____| |",

"|  _____  |",

'| |     | |',

'| |_____| |',

'|_|_____|_|']

t2=[" ________",

"| |____| |",

"|   __   |",

"|  (__)  |",

"|        |",

"|________|"]

t3=[" ______",

"| |__| |",

"|  ()  |",

"|______|"]

while True:

   try:

       f=int(input("Выберите рисунок цифрами 1-3 или 0 для выхода:"))

       if f==1:

           vivod(t1)

       elif f==2:

           vivod(t2)

       elif f==3:

           vivod(t3)

       elif f==0:

           break

   except ValueError:

       print("Неверный ввод")

Пояснення:

Новые вопросы