Составьте программу, запрашивающую у пользователя K целых чисел и вычисляющую произведение положительных.
Пример работы:
Окно вывода
Сколько чисел обработать? 5
Введите число 2
Введите число
Введите число
Введите число
Введите число
Произведение положительных чисел из 5 составляет 24
памагите а то я уже сижу рыдать начинаю (через паскаль надо сделать...)
Ответы на вопрос
Ответил Аноним
0
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Сколько чисел обработать?');
var s:=1;
loop n do begin
var k:=ReadInteger('Введите число');
if k>0 then s*=k
end;
Writeln('Произведение положительных чисел из ',n,' составляет ',s)
end.
Пример
Сколько чисел обработать? 5
Введите число 7
Введите число -4
Введите число 0
Введите число 9
Введите число -2
Произведение положительных чисел из 5 составляет 63
Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Сколько чисел обработать?');
var s:=1;
loop n do begin
var k:=ReadInteger('Введите число');
if k>0 then s*=k
end;
Writeln('Произведение положительных чисел из ',n,' составляет ',s)
end.
Пример
Сколько чисел обработать? 5
Введите число 7
Введите число -4
Введите число 0
Введите число 9
Введите число -2
Произведение положительных чисел из 5 составляет 63
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Математика,
8 лет назад
Обществознание,
9 лет назад