Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от -20 до 20. Подсчитайте в этом массиве количество положительных и количество отрицательных значений.(на паскале)
Ответы на вопрос
Ответил 503vicusya
19
Вот программа!Все работает правильно!
Приложения:

Ответил mmmegakilll
36
Program sadadasf;
var i,l,h,g: integer;
A: Array[1..101] of integer;
begin
For i:=1 to 100 do
begin
l:=random(41)-20;
A[i]:=l;
If l<0 then h:=h+1;
If l>0 then g:=g+1;
end;
Writeln('Количество отрицательных чисел:', h);
Writeln('Количество положительных чисел:', g);
end.
var i,l,h,g: integer;
A: Array[1..101] of integer;
begin
For i:=1 to 100 do
begin
l:=random(41)-20;
A[i]:=l;
If l<0 then h:=h+1;
If l>0 then g:=g+1;
end;
Writeln('Количество отрицательных чисел:', h);
Writeln('Количество положительных чисел:', g);
end.
Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
Физика,
2 года назад
Английский язык,
2 года назад
Математика,
7 лет назад
Математика,
7 лет назад