Составьте программу замены нулевых элементов таблицы единицами
Контрольный пример n=5
Данные :(0,5,0,60,0)
Результат :(1,5,1,60,1)
Пожалуйста
Ответы на вопрос
Ответил archery
0
//PascalABC.NET 3.1 сборка 1219
begin
var a := ArrRandomInteger(ReadInteger('n ='), 0, 10);
a.Println;
a.Transform(x -> (x = 0) ? 1 : x);
a.Println;
end.
правка вашего решения
const
n = 5;
var
x: array[1..n] of integer;
i, h: integer;
begin
for i := 1 to n do
begin
Readln(x[i]);
if (x[i] = 0) then x[i] := 1;
end;
for i := 1 to n do
Write(x[i], ' ');
readln;
end.
begin
var a := ArrRandomInteger(ReadInteger('n ='), 0, 10);
a.Println;
a.Transform(x -> (x = 0) ? 1 : x);
a.Println;
end.
правка вашего решения
const
n = 5;
var
x: array[1..n] of integer;
i, h: integer;
begin
for i := 1 to n do
begin
Readln(x[i]);
if (x[i] = 0) then x[i] := 1;
end;
for i := 1 to n do
Write(x[i], ' ');
readln;
end.
Новые вопросы