Составьте программу замены местами в массиве В(16) второго и предпоследнего элемента. Ввести старый и новый массивы. И если получиться создайте блок схему)
Ответы на вопрос
Ответ:
#include <iostream>
#include <cmath>
using namespace std;
int main() {
int B[16]; // создаём пустой массив
srand(time(NULL)); // делаем так что бы функция rand() зависла от времени и не была постоянной
for(int i = 0; i < 16; i++) { // заполняем массив случайными числами
B[i] = rand() % 100;
}
for(int i = 0; i < 16; i++) { // выводим массив
cout << B[i] << ", ";
}
cout << endl;
int tmp = B[1]; // создаём временну переменную для хранения значения 2 элемента массива
B[1] = B[14]; // присваиваем 2 элементу значение предпоследенго
B[14] = tmp; // присваиваем предпоследенему элементу значение временной переменной
for(int i = 0; i < 16; i++) { // выводим массив
cout << B[i] << ", ";
}
cout << endl;
}
Объяснение: