Информатика, вопрос задал lei1212 , 7 лет назад

Составьте программу, выполняющую вычисления по заданной формуле. Исходные данные вводятся с клавиатуры m=8, n =3. Программа должна обеспечить вывод пояснений перед запросом исходных данных.

Приложения:

Ответы на вопрос

Ответил y702019
0

Ответ:

Program YouName;

Uses crt; // Использование модуля crt.

Const e = 2.71828; // Объявление константы e.

Var // Раздел для описания переменных.

m,n: Integer; // Объявляем целочисленные переменные.

x,u,y: Single; // Объявляем дробные переменные.

Label check1, check2; // Объявляем метки для оператора Goto.

Begin // Начало "тела" программы.

 check1: // Метка для без условного перехода с оператора Goto.

write('Введите m: '); // Вывод текстового сообщения на экран консоли.

// {$I-} - это деректива, которая перехватывает вывод ошибок.

// т.e., если во время выполнение программы между {$I-} и {$I+} не будет ошибок,

// то значение IOResult будет равно 0. Если во время выполения программы произойдет ошибка,

// то программа не остановится, а задаст значение IOResult неравное 0.

// {$I+} соответственно отключает дерективу.

{$I-} // Включение директивы.

readln(m); // Ввод значения переменной m.

{$I+} // Отключение директивы

If IOResult <> 0 then // Если IOResult не равно 0 (т.е есть ошибки во время включенной директивы $I), то..

  Begin // Начало подпрограммы.

   writeln('Вы ввели неизвестный символ.'); // Вывод текстового сообщения на экран консоли.

   writeln('Введите число'); // Вывод текстового сообщения на экран консоли.

   Goto check1; // Переход на метку check1

  End; // Конец подпрограммы.

check2: // Метка для без условного перехода с оператора Goto.

write('Введите n: '); // Вывод текстового сообщения на экран консоли.

{$I-} // Включение директивы.

readln(n); // Ввод значения переменной n.

{$I+} // Отключение директивы.

If IOResult <> 0 then // Если IOResult не равно 0 (т.е есть ошибки во время включенной директивы $I), то..

  Begin // Начало подпрограммы.

   writeln('Вы ввели неизвестный символ.'); // Вывод текстового сообщения на экран консоли.

   writeln('Введите число'); // Вывод текстового сообщения на экран консоли.

   Goto check2; // Переход на метку check2

  End; // Конец подпрограммы.

x:=(m*n-exp(ln(e)*((-m)*0.7)))/(2.67); // Вычисление x

y:=ln(2)*(m+1); // Вычисление y

u:=0.125*sqrt(x/y)+exp(ln(e)*cos(x-y)); // Вычисление u

writeln(u:0:4); // Вывод текстового сообщения на экран консоли.

// u:0:4 - это задает переменной u четыре знака после запятой.

End. // Конец "тела" программы.

Ответил lei1212
0
Спасибо большое!
Новые вопросы