Составьте программу, вычисляющую, сколько раз в строке X встречается слово Y. Строку X и слово Y введите с клавиатуры.
Ответы на вопрос
Ответил petyaGavrikov
0
var x,y,z:string; k,p,l:integer;
begin
writeln('Введите строку:');
readln(x);
writeln('Введите слово:');
readln(y);
z:=x; k:=0;
l:=length(y);
p:=pos(y,x);
while p>0 do
begin
k:=k+1;
delete(z,p,l);
p:=pos(y,z);
end;
writeln('k = ',k);
end.
Пример:
Введите строку:
мама мыла раму, мама мыла окно.
Введите слово:
мама
k = 2
begin
writeln('Введите строку:');
readln(x);
writeln('Введите слово:');
readln(y);
z:=x; k:=0;
l:=length(y);
p:=pos(y,x);
while p>0 do
begin
k:=k+1;
delete(z,p,l);
p:=pos(y,z);
end;
writeln('k = ',k);
end.
Пример:
Введите строку:
мама мыла раму, мама мыла окно.
Введите слово:
мама
k = 2
Новые вопросы
Русский язык,
2 года назад
Математика,
2 года назад
Физика,
8 лет назад
Обществознание,
8 лет назад
Химия,
9 лет назад
Химия,
9 лет назад