Информатика, вопрос задал innesa1702 , 9 лет назад

Составьте программу, вычисляющую, сколько лет потребуется для удвоения вложенной суммы при годовом приросте 10%.

Ответы на вопрос

Ответил 2workaway
0
Есть такое правило, называется правило 70
T~=70/r
T-колличество лет
R - годовой процент роста
Потребуется примерно 7 лет
Ответил innesa1702
0
Спасибо!
Ответил innesa1702
0
Программа на Pascal ABC
Ответил archery
0
ваше правило 70 конечно возле но с ошибкой около полутора лет
Ответил archery
0
begin for var i := 1 to 99 do begin var s := 100.0; var s1:= s; var n := 0; repeat s1:= s1 + i/100*s1; n := n+1; until s1 >= 2 * s; writeln(i , ' - ',n - 70/i); end; end.
Ответил archery
0
begin  var s := 100.0;  var s1:= s;  var n := 0;  repeat    s1:= s1 + 0.1*s1;    n := n+1;  until s1 >= 2 * s;  writeln(n);end.
Ответил innesa1702
0
Спасибо!
Ответил 2workaway
0
это правило может ошибаться только при R>10%,
Ответил 2workaway
0
при всех остальных r оно дает довольно точные результаты
Ответил 2workaway
0
возможно вы рассматриваете базовый год как первый?
Ответил archery
0
что такое базовый год?
Новые вопросы