Информатика, вопрос задал славапро1ьввж , 9 лет назад

Составьте программу вычисляющую произведение квадратов всех чисел от 1 до n

Ответы на вопрос

Ответил Gleb1Kosyrev
0
var n,s,i:integer;
begin;
s:=1;
readln(n);
for i:=1 to n do
s:=s*sqr(i);
writeln(s);
end.
Ответил maonang
0
var i,n,Result_math:integer;
begin
   Write('Введите число n от 1 до 31: ');
   repeat 
      Readln(n);
   until not((n<1) or (n>31));
   Result_math:=1;
   for i:=1 to n do
      Result_math:=Result_math*i;
   Writeln('Произведение от 1 до ',n,' равно ',Result_math);
end.
Новые вопросы