Информатика, вопрос задал kyt5kyt6 , 7 лет назад

составьте программу, вычисляющую количество цифр введенного натурального числа
Pascal ABC


restIess: ну таких программ же куча уже...
kyt5kyt6: жду ответ, я не нашёл
restIess: Они есть, но в первых поисковых запросах немного сложнее для новичка, чем у меня сейчас)

Ответы на вопрос

Ответил restIess
3

var n, counter : integer;

begin

counter := 0;

writeln('Введите число: ');

readln(n);

while n > 0 do

begin

counter := counter + 1;

n := n div 10;

end;

writeln('Количество цифр в данном числе: ', counter);

end.


kyt5kyt6: https://prnt.sc/1rl3f35
restIess: куда у тебя делся раздел объявления, который у меня есть?)
hxhdbd26: Var
Новые вопросы