Составьте программу вычисления выражения (разными способами, применяя каждый из операторов while,repeat,for) a^p, где p - целое число. Pascal / очень надо.
Ответы на вопрос
Ответил Pyro00
0
1)Это с помощью while
var a,p,i,c:integer;
begin
readln(a);
readln(p);
c:=1; i:=0;
while i<p do
begin
c:=c * a;
inc(i);
end;
writeln(c);
readln;
end.
2) Это с помощью repeat
var a,p,i,c:integer;
begin
readln(a);
readln(p);
c:=1; i:=0;
repeat
c:=c * a;
inc(i);
until i=p;
writeln(c);
readln;
end.
3) Это с помощью for
var a,p,i,c:integer;
begin
readln(a);
readln(p);
c:=1;
for i:=1 to p do
c:=c * a;
writeln(c);
readln;
end.
var a,p,i,c:integer;
begin
readln(a);
readln(p);
c:=1; i:=0;
while i<p do
begin
c:=c * a;
inc(i);
end;
writeln(c);
readln;
end.
2) Это с помощью repeat
var a,p,i,c:integer;
begin
readln(a);
readln(p);
c:=1; i:=0;
repeat
c:=c * a;
inc(i);
until i=p;
writeln(c);
readln;
end.
3) Это с помощью for
var a,p,i,c:integer;
begin
readln(a);
readln(p);
c:=1;
for i:=1 to p do
c:=c * a;
writeln(c);
readln;
end.
Ответил gasirbek
0
вы наверно поняли что a в степени p ?
Ответил Pyro00
0
ну да
Ответил Pyro00
0
а там иначе?
Новые вопросы
Биология,
2 года назад
История,
2 года назад
Математика,
8 лет назад
Математика,
8 лет назад
Математика,
9 лет назад