Составьте программу вычисления в одномерном массиве минимального элемента и его номера.
Ответы на вопрос
Ответил Seantrex
0
1)
var
a: array [1..100] of longint;
i,j,k,n:longint;
begin
readln(n);
for i:=1 to n do readln(a[i]);
k:=a[1]; j:=1;
for i:=1 to n do
if a[i]<k then begin k:=a[i]; j:=i; end;
writeln(k, ' ',j);
end.
var
a: array [1..100] of longint;
i,j,k,n:longint;
begin
readln(n);
for i:=1 to n do readln(a[i]);
k:=a[1]; j:=1;
for i:=1 to n do
if a[i]<k then begin k:=a[i]; j:=i; end;
writeln(k, ' ',j);
end.
Ответил Sky09
0
uses crt;
const N=10;
var a:array [1..N] of integer;
x,y,min:integer;
begin
for x:=1 to N do
begin
write('a[',x,']:');
readln(a[x]);
end;
min:=a[1];
y:=1;
for x:=1 to N do
if a[x]<min then
begin
min:=a[x];
y:=x;
end;
writeln('min[',y,']:',min);
end.
const N=10;
var a:array [1..N] of integer;
x,y,min:integer;
begin
for x:=1 to N do
begin
write('a[',x,']:');
readln(a[x]);
end;
min:=a[1];
y:=1;
for x:=1 to N do
if a[x]<min then
begin
min:=a[x];
y:=x;
end;
writeln('min[',y,']:',min);
end.
Новые вопросы
Қазақ тiлi,
2 года назад
Русский язык,
2 года назад
Физика,
10 лет назад
Химия,
10 лет назад
Физика,
10 лет назад