Составьте программу вычисления в массиве В, состоящем из восьми элементов, суммы отрицательных элементов.
паскаль
Ответы на вопрос
Ответил антагонист
0
var a,b,sum:integer;
arr :array [0..7] of integer;
begin
sum:=0;
write('введите элементы массива : ');
for a:=0 to 7 do begin
read(b);
arr[a]:=b;
end;
for a:=0 to 7 do begin
if arr[a]<0 then sum:=sum+arr[a];
end;
writeln('сумма отрицательных элементов массива = ',sum);
end.
arr :array [0..7] of integer;
begin
sum:=0;
write('введите элементы массива : ');
for a:=0 to 7 do begin
read(b);
arr[a]:=b;
end;
for a:=0 to 7 do begin
if arr[a]<0 then sum:=sum+arr[a];
end;
writeln('сумма отрицательных элементов массива = ',sum);
end.
Новые вопросы
Биология,
2 года назад
Математика,
9 лет назад
Математика,
9 лет назад
Математика,
9 лет назад
Литература,
9 лет назад