Информатика, вопрос задал SchokkovaЯ , 8 лет назад

Составьте программу вычисления суммы повторяющихся элементов одномерного массива. (паскаль)

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-20,20); a.Println;
  Writeln('Sдубл=',a.GroupBy(c->c).Select(c->(c.Key,c.Count))
      .Where(c->c[1]>1).Select(c->c[0]*c[1]).Sum)
end.

Пример
n= 15
1 2 -10 18 8 -18 -8 -6 -11 -7 -10 -11 3 2 2
Sдубл=-36

Новые вопросы