Составьте программу вычисления суммы нечетных делителей нату-
рального числа M, больша Р.
fovfabomi:
язык какой?
Ответы на вопрос
Ответил fovfabomi
0
var m,p,d,s:integer;
begin
writeln('введите m');
readln (m);
s:=0;
writeln('введите p');
readln (p);
if p mod 2 = 1 then d:=p+2 else d:=p+1;
while d<=m do begin
if m mod d = 0 then s:=s+d; d:=d+2
end;
writeln(s);
end.
Новые вопросы
Русский язык,
2 года назад
Математика,
2 года назад
Русский язык,
2 года назад
Физика,
8 лет назад
Математика,
8 лет назад