Составьте программу вычисления суммы факториалов всех чётных чисел от m до n.
Ответы на вопрос
Ответил angryfukse
0
var
m, n, i: integer;
sum: real;
function fact(x: integer): real;
begin
if x = 0 then fact := 1
else fact := fact(x - 1) * x;
end;
begin
writeln('Введите границы m и n соответственно : ');
readln(m, n);
sum := 0;
for i := m to n do if not odd(i) then
sum := sum + fact(i);
writeln('Сумма факториалов четных чисел последовательности = ', sum);
end.
Новые вопросы
Другие предметы,
2 года назад
Информатика,
7 лет назад
Математика,
7 лет назад
Математика,
9 лет назад
Математика,
9 лет назад