Информатика, вопрос задал ach01 , 9 лет назад

Составьте программу вычисления степени числа а с натуральным показателем n. (Записать варианты программы с разными видами циклов while, repeat, for).

Ответы на вопрос

Ответил Kalash12
0
//////////////////////////FOR
Var   a, i, n, sum: integer;  
Degin  
  ReadLn(a, n);  
  Sum := 1;  
   For i := 1 to n do sum := sum * a;  
  WriteLn(sum);
End.

//////////////////////////WHILE
Var   a, i, n, sum: integer;  
Begin  
 Read(a, n);  
 Sum := 1;  
  While i <> n do  
   Begin    
    Sum := sum * a;  
    Inc(i);  
   End;  
 Writeln(sum);
End.

//////////////////////////REPEAT
Var   a, i, n, sum: integer;  
Begin  
 Read(a, n);  
 Sum := 1;  
  If n <> 0 then    
   Repeat      
     Begin        
       Sum := sum * a;        
       Inc(i);      
     End;    
   Until i = n;  
  WriteLn(sum);
End.
Новые вопросы