Составьте программу вычисления произведения тех значений элементов одномерного массива, которые меньше 32.
Ответы на вопрос
Ответил ingr
0
program proizvedenie;
var
n : integer;
p : integer := 1;
d : array of integer;
k : boolean;
begin
write('введите длину массива ');
readln(n);
d := new integer[n];
d := arrRandom(n, 1, 64);
writeln('сгенерирован массив: ', d);
for var i := 0 to n-1 do if d[i] < 32 then begin
p *= d[i];
k := true;
end;
if k then writeln('произведение всех членов массива со значением меньших 32 равно ', p)
else writeln('массив не имеет значений меньше 32');
end.
Новые вопросы
Другие предметы,
2 года назад
Английский язык,
2 года назад
Математика,
7 лет назад
Литература,
9 лет назад