Составьте программу вычисления произведения простых делителей натурального числа N.
Ответы на вопрос
Ответил Royal21
0
var
x,i,n: integer;
begin
x:=1;
write('Введите натуральное число: ');
read(n);
write('Простые делители числа ',n,': ');
for i:= 1 to n do
if n mod i = 0 then
begin
write(i:4);
x:=x*i;
end;
writeln;
writeln('Их произведение: ',x);
end.
x,i,n: integer;
begin
x:=1;
write('Введите натуральное число: ');
read(n);
write('Простые делители числа ',n,': ');
for i:= 1 to n do
if n mod i = 0 then
begin
write(i:4);
x:=x*i;
end;
writeln;
writeln('Их произведение: ',x);
end.
Новые вопросы