Информатика, вопрос задал kosmosnikita , 9 лет назад

составьте программу вычисления произведения последних четырех элементов одномерного массива A(N), заполнив его случайным образом

Ответы на вопрос

Ответил vladmor
0
Вариант №1

//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
begin
  var n:=ReadInteger('Размер массива: ');
  var a:=ArrRandom(n);
  a.Println;
  var p:=1;
  for var i:=n-4 to n-1 do begin
    p:=p*a[i];
  end;
  println(p);
end.

Тестовое решение:

Размер массива:  10
26 65 88 43 49 93 67 40 16 84
3601920

Вариант №2

const k = 100;
var a:array [1..k] of integer;
i,p,n:integer;
begin
  p:=1;
  readln(n);
  for i:=1 to n do begin
    a[i]:=random(21)-10;
    write(a[i]:4);
    if i>n-4 then p:=p*a[i];
  end;
  writeln;
  writeln(p);
end.

Тестовое решение:

10
  -8   6   1   3   1 -10  -3   2   2   2
-24




Ответил kosmosnikita
0
println итд не примет нужно через writeln
Ответил vladmor
0
Вы какой версией языка пользуетесь?
Ответил kosmosnikita
0
5.1. 2006
Ответил vladmor
0
Минут через 5 добавлю в решение одругой вариант
Ответил vladmor
0
Готово, смотрите вариант №2
Новые вопросы