Составьте программу вычисления произведения P=1*3*5*...*23 (в паскале)
Ответы на вопрос
Ответил BrightOne
0
program ca;
var
p, i: integer;
begin
i := 3;
p := 1;
while i <= 23 do
begin
p := p * i;
i := i + 2;
end;
writeln('p = ', p);
end.
var
p, i: integer;
begin
i := 3;
p := 1;
while i <= 23 do
begin
p := p * i;
i := i + 2;
end;
writeln('p = ', p);
end.
Ответил BrightOne
0
Хм, вы правы - там поболе 4 байтов будет. А что в Паскале (желательно в "общем для всех" Паскале) есть типа long в C/C++?
Новые вопросы