Информатика, вопрос задал ForKStaR , 10 лет назад

Составьте программу вычисления площади кольца с внутренним радиусом R1 и внешним радиусом R2.Значения R1 и R2 введите с клавиатуры

Ответы на вопрос

Ответил Lukmore
0

Если твое кольцо есть фигура Тор, то это внешний и внутренний радиусы. (Внешний больше). Тогда код вот такой:

 

uses crt;
var
r1,r2: real;
begin
read(r1,r2);
writeln(pi*(r1*r1-r2*r2):0:3);
end.

Новые вопросы