составьте программу вычисления корней квадратного уравнения по данным значениям его коэффициентов.
Ответы на вопрос
Ответил Аноним
0
Var A, B, C, D, X, X1, X2 : Real;
Begin
Writeln ('Введите коэффициенты уравнения (A, B, C) ');
readln(a,b,c);
If A=0 Then
If B=0 Then
If C=0 Then Writeln('X - любое число')
Else Writeln('Корней нет! ')
Else
Begin
X:=-C/B;
Writeln('X=',X:8:3);
End
Else
Begin
D:=B*B-4*A*C;
If D<0 Then Writeln ('Корней нет! ')
Else
Begin
X1:=(-B+SQRT(D))/2/A;
X2:=(-B-SQRT(D))/2/A;
Writeln ('X1=', X1:8:3, ' X2=',X2:8:3);
End;
End;
End.
Begin
Writeln ('Введите коэффициенты уравнения (A, B, C) ');
readln(a,b,c);
If A=0 Then
If B=0 Then
If C=0 Then Writeln('X - любое число')
Else Writeln('Корней нет! ')
Else
Begin
X:=-C/B;
Writeln('X=',X:8:3);
End
Else
Begin
D:=B*B-4*A*C;
If D<0 Then Writeln ('Корней нет! ')
Else
Begin
X1:=(-B+SQRT(D))/2/A;
X2:=(-B-SQRT(D))/2/A;
Writeln ('X1=', X1:8:3, ' X2=',X2:8:3);
End;
End;
End.
Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
Физика,
10 лет назад
Обществознание,
10 лет назад
Геометрия,
10 лет назад
Алгебра,
10 лет назад