Составьте программу вычисления количества трёхзначных чисел, у которых цифры упорядочены строго по возрастанию
Ответы на вопрос
Program Pr;
var a:array[100..999] of integer;
q,w,v,c,i,d:integer;
Begin
n:=-1;
c:=1;
For i:=1 to 899 do begin
a[i]:=99+c;
c:=c+1;
q:=a[i] mod 10;
a[i]:=a[i] div 10;
w:=a[i] mod 10;
a[i]:=a[i] div 10;
if (q>w) and (q>a[i]) and (w>a[i]) then v:=v+1;
end;
writeln('Всего этих числел=',v);
end.
var
i, n: integer;
i1, i2, i3: 1..9; //Цифры трехзначного числа
begin
for i:= 100 to 999 do {Перебираем все трехзначные числа и вычисляем цифры числа}
begin
i1:= i div 100;
i2:= (i mod 100) div 10;
i3:= i mod 10;
if (i3 > i2) and (i2 > i1) then inc(n); {Если 3 цифра больше 2-й и 2-я больше 1-ой, то увеличиваем счетчик на 1}
end;
writeln('Количество трехзначных чисел, у которых цифры упорядочены строго по возрастанию равно: ', n);
end.
Если все правильно, отметь решение как лучшее)