Информатика, вопрос задал NikaAddams , 10 лет назад

Составьте программу вычисления функции:

у= left { {{-2 x^{2} +x +1,x leq 0} atop {-2 x^{2} + 3, x>0}} right.

Ответы на вопрос

Ответил HRAshton
0
var
  x: real; //Пусть будут (почти) любые числа

begin
  readln(x); // вводим
  writeln(-2 * sqr(x) + (x <= 0 ? x + 1 : 3)); //Тернары - добро, ибо код меньше:
                                                           //(условие ? вывод при истине : вывод иначе)
end.
Новые вопросы