составьте программу вычисления диагоналей параллелограмма по сторонам и углу
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1541 от 29.09.2017
// Внимание! Если программа не работает, обновите версию!
begin
var (a,b,ag):=ReadReal3('Введите размеры сторон и угол между ними:');
var d1:=Sqrt(a*a+b*b-2*a*b*Cos(DegToRad(ag)));
var d2:=Sqrt(a*a+b*b-2*a*b*Cos(DegToRad(180-ag)));
Writeln('d1=',d1,', d2=',d2);
end.
Пример
Введите размеры сторон и угол между ними: 5 2 60
d1=4.35889894354067, d2=6.2449979983984
// Внимание! Если программа не работает, обновите версию!
begin
var (a,b,ag):=ReadReal3('Введите размеры сторон и угол между ними:');
var d1:=Sqrt(a*a+b*b-2*a*b*Cos(DegToRad(ag)));
var d2:=Sqrt(a*a+b*b-2*a*b*Cos(DegToRad(180-ag)));
Writeln('d1=',d1,', d2=',d2);
end.
Пример
Введите размеры сторон и угол между ними: 5 2 60
d1=4.35889894354067, d2=6.2449979983984
Новые вопросы
Математика,
2 года назад
История,
2 года назад
Математика,
8 лет назад
Информатика,
8 лет назад
Математика,
9 лет назад