Составьте программу вычисление тех значений элементов массива которые меньше 16
Ответы на вопрос
Ответил srzontmp
0
const m=200;
var a: array[1..m] of integer;
i,n: integer;
begin
write('количество элементов массива: ');
readln(n);
randomize;
write('массив: ');
for i:=1 to n do
begin
a[i]:=random(40);
write(a[i],' ');
end;
writeln;
write('элементы, меньшие 16: ');
for i:=1 to n do if a[i]<16 then
write(a[i],' ');
end.
количество элементов массива: 15
массив: 6 22 28 39 24 3 19 15 35 22 2 2 22 1 32
элементы, меньшие 16: 6 3 15 2 2 1
var a: array[1..m] of integer;
i,n: integer;
begin
write('количество элементов массива: ');
readln(n);
randomize;
write('массив: ');
for i:=1 to n do
begin
a[i]:=random(40);
write(a[i],' ');
end;
writeln;
write('элементы, меньшие 16: ');
for i:=1 to n do if a[i]<16 then
write(a[i],' ');
end.
количество элементов массива: 15
массив: 6 22 28 39 24 3 19 15 35 22 2 2 22 1 32
элементы, меньшие 16: 6 3 15 2 2 1
Ответил petyaGavrikov
0
const n=10;
var a:array[1..n] of integer;
i,k:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
begin
a[i]:=random(31);
write(a[i]:4);
end;
writeln;
k:=0;
for i:=1 to n do
if a[i]<16 then k:=k+1;
writeln('Количество элементов массива < 16 = ',k);
end.
Пример:
Массив A:
17 28 18 19 12 9 24 6 18 12
Количество элементов массива < 16 = 4
var a:array[1..n] of integer;
i,k:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
begin
a[i]:=random(31);
write(a[i]:4);
end;
writeln;
k:=0;
for i:=1 to n do
if a[i]<16 then k:=k+1;
writeln('Количество элементов массива < 16 = ',k);
end.
Пример:
Массив A:
17 28 18 19 12 9 24 6 18 12
Количество элементов массива < 16 = 4
Новые вопросы
Геометрия,
8 лет назад
Математика,
9 лет назад