Информатика, вопрос задал MaryKod , 9 лет назад

Составьте программу в Паскале  выводящую значение TRUEFalse 
№9 Данное четырехзначн. число читается одинаково справа налево и слева на право 
и №11 Сумма каких-либо 2 цифр заданного натурального трехзначного числа N равна третьей цифре 

Ответы на вопрос

Ответил fasalv
0
№9

var n: integer;
begin
     readln(n);
     if (n mod 10 = n div 1000) and (n div 10 mod 10 = n div 100 mod 10) then
        writeln('TRUE')
     else
         writeln('FALSE');
end.
------------------
№11

var n, a, b, c: integer;
begin
     readln(n);
     c := n mod 10; {Третья цифра}
     b := n div 10 mod 10; {Вторая цифра}
     a := n div 100; {Первая цифра}
     if (a + b = c) or (a + c = b) or (b + c = a) then
        writeln('TRUE')
     else
         writeln('FALSE');
end.
Новые вопросы