Составьте программу в Паскале пожалуйста:
дан одномерный массив найдите разность наибольшего и наименьшего элемента этого массива
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
var a:=ArrRandom(ReadInteger('n='),-50,50);
a.Println;
Writeln('Разность: ',a.Max-a.Min)
end.
Тестовое решение:
n= 15
28 -35 2 25 20 -48 47 24 1 9 17 24 -32 -41 -14
Разность: 95
begin
var a:=ArrRandom(ReadInteger('n='),-50,50);
a.Println;
Writeln('Разность: ',a.Max-a.Min)
end.
Тестовое решение:
n= 15
28 -35 2 25 20 -48 47 24 1 9 17 24 -32 -41 -14
Разность: 95
Ответил gdgv
0
просто это программа должна решаться с помощью массива)
Ответил Аноним
0
Вы должны сознавать, что уровень и стиль программирования, принятый в вашем классе - они вовсе не единственные в мире и догадаться об их конкретике никто не может.
Ответил Аноним
0
А она и решена с помощью массива. Переменная а - это массив, который создается при помощи процедуры ArrRandom.
Ответил Аноним
0
Можно явно написать
var a:array of integer:=ArrRandom(ReadInteger('n='),-50,50); только это ничего не изменит, просто код удлинит.
var a:array of integer:=ArrRandom(ReadInteger('n='),-50,50); только это ничего не изменит, просто код удлинит.
Ответил Аноним
0
Так что на будущее, если не устраивает подобный код, явно указывайте версию Паскаля.
Новые вопросы
Окружающий мир,
2 года назад
Математика,
2 года назад